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Warranty

What The Warranty Covers
AltiGen Communications warrants its hardware products to be free from defects in material 
and workmanship during the warranty period. If a product proves to be defective in material 
or workmanship during the warranty period, AltiGen Communications will, at its sole option, 
repair, refund or replace the product with a like product.

How Long the Warranty Is Effective
All AltiGen Communications products are warranted for one year for all parts from the date 
of the first end user purchase.

Whom the Warranty Protects
This warranty is valid only for the first end user purchaser.

What the Warranty Does Not Cover
1. Any product on which the serial number has been defaced, modified or removed.

2. Damage, deterioration or malfunction resulting from:

a) Accident, misuse, neglect, fire, water, lightning, or other acts of nature, 
unauthorized product modification, or failure to follow instructions supplied with 
the product.

b) Repair or attempted repair by anyone not authorized by AltiGen Communications.

c) Any damage of the product due to shipment.

d) Removal or installation of the product.

e) Causes external to the product, such as electric power fluctuations or failure.

f) Use of supplies or parts not meeting AltiGen Communications’ specifications.

g) Normal wear and tear.

h) Any other cause which does not relate to a product defect.

3. Shipping, installation, set-up and removal service charges.

How to Obtain Service
End user customers should contact your Authorized AltiGen Dealer for service. 

Authorized AltiGen Dealers must follow the steps below for service:
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1. Take or ship the product (shipment prepaid) to your AltiGen distributor or to AltiGen 
Communications, Inc.

All materials being returned to AltiGen must have an associated RMA number. RMA numbers 
are issued by AltiGen Technical Support and can be obtained by calling 1-888-258-4436 or 
faxing an RMA form to 510-252-9738, attention Technical Support. AltiGen reserves the right 
to refuse return of any material that does not have an RMA number. The RMA number should 
be clearly marked on the outside of the box in which the material is being returned. For 
example:

Attn.: RMA #123
AltiGen Communications, Inc.
4555 Cushing Pkwy.
Fremont CA 94538

Upon authorization of return, AltiGen will decide whether the malfunctioning product 
will be repaired or replaced.

2. To obtain warranty service, you will be required to provide:

a) the date and proof of purchase

b) serial number of the product 

c) your name and company name

d) your shipping address

e) a description of the problem.

3. For additional information contact your AltiGen Dealer or AltiGen Communications, Inc.

Effect of State Law
This warranty gives you specific legal rights, and you may also have other rights which vary 
from state to state. Some states do not allow limitations on implied warranties and/or do not 
allow the exclusion of incidental or consequential damages, so the above limitations and 
exclusions may not apply to you.

Sales Outside the U.S.A.
For AltiGen Communications products sold outside of the U.S.A., contact your AltiGen 
Communications dealer for warranty information and services.
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C H A P T E R  1

Overview and Installation

AltiGen MaxInSight is a workgroup performance application. It provides 
call center managers and agents with the ability to track workgroup status 
and performance data from a wall-mounted LCD panel or from their PCs.

MaxInSight includes the ability to see the following for single or multiple 
workgroups:

• Real-time queue status 

• Real-time workgroup resource status

• Daily operation results

• Trends of data over time

Users can configure:

• Several types of data displays, or views

• Alerting thresholds

• The display interval for different workgroups’ statuses when those 
workgroups are configured into in a single template

• Character font size and color

• The MaxInSight skin

MaxInSight runs with the MAX Communication Server ACC or ACM 6.0 
Update2 or later systems.

Licensing
MaxInSight requires an AltiGen MaxInSight session license. 

System Requirements

The client system must meet the following minimum requirements:

• IBM/PC AT compatible system

• 2 GHz CPU or above
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• Windows XP Professional SP3, Windows Vista Business Edition, or 
Windows 2003

• 1 GB available hard drive disk space

• 512 MB RAM

• SVGA monitor (1024 x 768) with 256 color display, or better

• Keyboard and mouse

• MAX Communication Server ACC 6.0 Update2 or MAX 
Communication Server ACM 6.0 Update2 running on a server 
accessible to this client.

Pre-Installation Checklist
Before installing MaxInSight, make sure the following is done:

• MAXCS ACC/ACM 6.0 Update2 has been installed on the system 
server.

• The MaxInSight License Key has been installed and activated on the 
system server.

• TCP/IP is enabled on both machines.

• The client is able to connect to the server on the network.

• The person installing MaxInSight has local administrator rights on the 
client PC.

Installing MaxInSight on a Client System
When the above items are done, follow these steps on the client machine:

1. Exit all Windows applications.

2. Insert the MAXCS 6.0 Update2 Clients CD into the CD ROM drive.

3. Open the MaxInSight folder, and run the Setup program in that 
folder, following the step-by-step installation instructions as they 
appear on the screen.

Alternatively, if your system administrator has loaded MaxInSight on a 
shared network server, you can copy the files in the MaxInSight folder to 
your desktop PC, and run the MaxInSight Setup program.
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Uninstalling MaxInSight
1. From the Windows Start menu, select Control Panel > Add/Remove 

Programs > MaxInSight to uninstall MaxInSight.

2. Click Remove, and respond to any additional prompts.
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C H A P T E R  2

Getting Started

Start MaxInSight from the Microsoft Windows Start menu, by choosing 
Start > All Programs > MaxInSight > MaxInSight.

If you are connecting to the Internet through a modem connection, before 
you log in, establish a session connection from your PC to your local 
Internet service provider. If you’re using a low-speed connection, the login 
may take some time, since a large amount of data is transferred to your 
desktop.

Logging In
1. If this is your first login to this MAX Communication Server ACC/

ACM system, enter the system server’s IP address or the name of the 
system server you will be using. To obtain the server name or IP 
address, ask your system administrator.

(Subsequently, when you log in, you’ll see the IP address in the Server 
field.)

2. Enter your Extension number and Password assigned to your phone. 
(You can also log in as a workgroup or a huntgroup.)



6 MaxInSight Manual

If you want to store your login password and have it entered 
automatically the next time you log in to MaxInSight, check the 
Always save password check box. 

3. Click Sign in or press the Enter key. (To back out of logging in, press 
the Esc key.) The Choose Data Source dialog box appears:

4. Select a log service. Only enabled and connected log servers can be 
selected. (The number of entries listed in the Choose Data Source 
dialog box depends on the number of logger servers installed with the 
MAX Communication Server.) 

When Connection Is Broken
When a connection with the phone server is broken, a message box pops up 
letting you know. After you click OK in the message box, the application 
closes, and you will need re-launch it.

The MaxInSight Main Window
Once you log in to MaxInSight, a blank main window appears. It has a 
menu bar at the top, containing Configure, Add, View, and Help menus. 
The figure below shows the Configure menu.
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Figure 1. MaxInSight main window with the Configure menu opened

MaxInSight remembers the workgroups you enable, and the configuration 
and position of views, so when you log in again, the remembered 
workgroups are enabled automatically, and the views are displayed as they 
were when you logged out.

Making Workgroups Available for Monitoring
Before you can monitor a workgroup, you must enable it. To do so, choose 
Configure > Configure WG to Monitor. 

Click a column 
head to sort the 
column in 
ascending or 
descending order
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All workgroups configured in your company’s MAX Communication 
Server are listed in this dialog box. Select a workgroup you want to 
monitor, and click the Enable button. Enter the workgroup password when 
requested. Repeat for each group you want to monitor. Workgroups you 
enable will be available to you in other MaxInSight configuration screens. 
When finished, click OK.

To disable a workgroup, select it and click the Disable button. Workgroups 
that you disable will not be available in other MaxInSight configuration 
screens.

Arranging the Display
After you have configured views (see “Configuring Data Displays” on page 
13), you can control the MaxInSight display with the following methods.

• Using commands on the View menu (and keyboard equivalent): 

Full Screen enlarges a view to fill the screen and hides the MaxInSight 
title bar and menus. To get the MaxInSight main window and its 
menus back, press Ctrl+U (Ctrl+U is a toggle) or the Esc key. You 
can also right-click on the border of the MaxInSight screen (not within 
a view) and choose View > Full Screen/Restore. 

Arrange View fills the MaxInSight window with an orderly 
distribution of each view. For an example, see Figure 2, below.

The bottom of the View menu lists your current views. The view 
appearing first in your display is checked. To make another view the 
first displayed, click it in the menu list, and then choose View > 
Arrange View. The newly selected view now appears first.

• Using commands on the right-click menu: in some situations, the 
commands are Minimize, Maximize, Restore, Close. When you are 
working in Full Screen, the commands Full Screen/Restore and 
Arrange are available if you right-click on the border of the 
MaxInSight screen (not within a view).

• Moving the windows in the standard Windows fashion:
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Resize the MaxInSight window and view windows by placing the 
cursor at a window edge or corner, then drag the window to the size 
you want.

Move a window by clicking and dragging its title bar.

Dismiss a window by clicking the close button in the upper right 
corner. 

Minimize a window by clicking its Minimize button.

Figure 2. Result of choosing the View > Arrange View command to display five 
configured views

Changing the Skin
You can select a skin for MaxInSight. The skin defines the title bar and 
border of the main MaxInSight window and view windows. Choose 
Configure > Configure Skin. The following dialog box is displayed: 
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In this dialog box, you can 

• Select a skin (the display in the dialog box changes to show you what 
the skin looks like)

• Specify font name and color for the title window of views

• Specify a background image for the main window by clicking the 
Choose button to pop up an Open dialog box:

Choose a .bmp image file from any folder, and click the Open button.
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• Choose to remove the AltiGen logo from the background of the Main 
window by clearing the Display AltiGen logo on the background 
check box.
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C H A P T E R  3

Configuring Data Displays

After you have enabled the workgroups you want to monitor (Configure > 
Configure Workgroup to Monitor), you can then configure the data 
displays you want to see.

Configuring Workgroup Data Displays
You can display rows of workgroup data in the following ways: 

• One workgroup only

• Multiple workgroups in rotating views, one workgroup at a time

• Multiple workgroups on display at the same time

In addition to row views, you can also create gauge views, time line views, 
and bar views.

You can configure individual fields to alert you when specified thresholds 
are reached. See “Configuring Alerts” on page 24.

Configuring for a Single Row-Type Display
To configure a row view for a single workgroup or multiple workgroups in 
a rotating display, choose Add > Add Single Workgroup View. 

A configuration dialog box opens, listing the workgroups you have 
enabled:
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1. To select a workgroup, highlight it and click the Right-arrow button. 
You can select multiple workgroups to monitor, but in this 
configuration only one workgroup view at a time is displayed. When 
multiple workgroups are selected, the data of each one is displayed in 
rotation. You can specify the order of the rotating display by arranging 
the order of the selected workgroups: highlight a workgroup and click 
the Up or Down arrow button to move it to where you want it.

2. Select the fields you want to monitor. The fields are arranged in three 
categories: Queue, Workgroup, Agent. To see an explanation of each 
field (appearing just above the fields list), highlight the field.

Select 
WGs to 
view

Highlight a 
field to see 
it described 
here
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Use Shift+click to select multiple adjacent fields. Use Ctrl + click to 
select multiple non-adjacent fields. Then click the Right-arrow button 
to move them to the right-hand column. To remove fields, select them 
and click the Left-arrow button. You can change the order of selected 
fields by highlighting a field and clicking the Up or Down buttons.

3. In the Row Count field, specify the number of rows to use to display 
the fields you have selected. In the following example, six fields were 
selected, and Row Count was set to 2:

Figure 1. Data from a single workgroup is displayed

4. If you have selected more than one workgroup, specify in the Rotate 
Interval field how many seconds you want to display one workgroup 
view before MaxInSight rotates to the next group’s view.

5. In the Field Name panel, specify a font and a color for the field names. 

6. In the Field Value panel, specify a font and the maximum number of 
digits to display in a field. If the field value is more than the maximum 
number of digits specified, then "?" will be displayed. For example if 
the maximum number of digits is set to 2 but the field value is 123, then 
the content display on the view will be “1?”. 

Note: Font color for the field value is set in the Alerting 
Configuration dialog box (Configure > Configure Alerting).

7. In the WG panel, specify a color for the workgroup number.

Configuring Simultaneous Row-Type Views of Multiple 
Groups
To configure simultaneous row views of multiple workgroups, choose Add 
> Add Multiple Workgroup View. The configuration dialog box for 
multiple workgroup views is similar to that for a single workgroup display. 

In this example, data 
is configured to be 
displayed in two 
rows.
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To configure, see the steps in “Configuring for a Single Row-Type 
Display” on page 13. 

In a multiple workgroup view, each workgroup’s data is displayed in a 
separate row. The first column displays the number of the workgroup.

Figure 2. Data from two workgroups displayed, each in its own row
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Configuring Other Data Displays
In addition to the basic row views, you can configure four other views:

Gauge - used to show the real time status of a single data value in a dial 
format.

Timeline - used to display trends of data elements over time. The data 
points are plotted on the graph and connected with lines.

Vertical or Horizontal Bars - used to display one field of either one 
workgroup or multiple workgroups in a vertical or horizontal bar view. 
This view reflects either historical data or real time data, whichever you 
specify.

Gauge View
A gauge view displays the status of a single field in an easy-to-read dial 
format. With a gauge view and with alerting configured, it’s easy to see, for 
example, whether service level is normal or too low, the number of callers 
in queue is too high, or queue time is too long.

To set parameters for a gauge view, 

1. Choose Add > Add Gauge View. The Set Gauge View Parameters 
dialog box opens:

2. Specify the workgroup, the field to track, and a value range.
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Note: Only the fields appropriate to a gauge view are available

3. Select a font and color for the workgroup and for the field name.

4. Click OK.

A gauge view is displayed similar to the following:

Figure 3. Gauge view set to show % of abandoned calls, up to 16 calls

Time Line View
A time line view is used to display trends of data elements over time. The 
data points are plotted on a graph and connected with lines.

To set parameters for a time line view,
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1. Choose Add > Add Time Line View. The Set Time Line View 
Parameters dialog box opens.

2. Select one or more workgroups. To select a workgroup, highlight the 
workgroup and click the Right-arrow button.

3. To specify the color of the lines, highlight a selected workgroup, click 
Set Color and select a color. Repeat for each additional workgroup.

4. From the Select Field drop-down list, select a field to chart . Only the 
fields of data from the logger service you specified at login will appear 
in the drop-down list. (The logger service is shown in the Current 
Data Source field.)

5. In the Value Range fields, specify a value range for the field you want 
to chart.

6. Specify the period for which you want to display statistics: either the 
last x hours (select from 1-24), or a time period you specify in the 
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From and To fields (24-hour clock). Be sure the time you select in the 
From field precedes the time you select in the To field.

7. Select a time interval: 15 minutes, 30 minutes, or one hour. 

8. Click OK. A time line view is displayed. The workgroup number(s) 
and display colors are shown at the top.

Figure 4. Time Line View showing number of incalls every 15 minutes for the last 
hour

Bar Views - Vertical and Horizontal
You can display one selected field of multiple workgroups in a bar view 
that shows either historical data or real time data. 

1. Choose either Add > Add Vertical Bar View or Add > Add 
Horizontal Bar View. The following dialog box appears.
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2. Select History to display historical data, or select Real Time to 
display real time data, and click OK. A dialog box opens where you 
can set parameters. 

If you selected History, the following dialog box opens: 

1. Select one or more workgroups. To select a workgroup, highlight 
the workgroup and click the Right-arrow button.

2. To specify the color of the bars, highlight a selected workgroup, 
click Set Color and select a color. Repeat for each workgroup 
selected.

3. To change the order of workgroups in a view, highlight a selected 
workgroup and click the Up or Down button.

4. Select a field to chart from the Select Field drop-down list. Only the 
fields of statistics data from the logger service you specified at login 
will appear in the drop-down list. (The logger service is shown in 
the Current Data Source field.)
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5. In the Value Range fields, specify a value range for the field you 
want to chart.

6. Specify the period for which you want to display statistics: either 
the last x hours (select from 1-24), or a time period you specify in 
the From and To fields (24-hour clock). Be sure the time you select 
in the From field precedes the time you select in the To field. 

7. Select a time interval for display: 15 minutes, 30 minutes, one hour. 

8. Click OK. A bar view is displayed. Workgroup number(s) and their 
display colors are shown at the top.

Figure 5. A vertical bar view showing history data for abandoned calls in two 
workgroups. (No calls were abandoned.)

Figure 6. A horizontal bar view showing history data for abandoned calls in two 
workgroups. (No calls were abandoned.)
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If you selected Real Time in the Bar View Display Mode dialog box, the 
following dialog box opens:

1. Select a workgroup.

2. Select a field to view.

3. Specify a value range for the field you want to view.

4. Click OK. A bar view is displayed. The workgroup number and 
display color are shown at the top.

Figure 7. Vertical bar view showing number of abandoned calls for a workgroup. 
(No calls were abandoned.)
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Changing the Parameters of a View
To change the parameters of a view you’re displaying in MaxInSight, right-
click the view, and choose Modify View Parameters. Make your changes 
in the Parameters dialog box and click OK.

Configuring Alerts
For each field you’re interested in tracking, you can choose to be alerted 
when data in the field crosses a threshold you specify (a warning threshold 
and a critical threshold). MaxInSight alerts you through a different color 
display and, optionally, by playing a sound file. 

To configure alerts for a field,

The right-click 
menu on a view
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1. Choose Configure > Configure Alerting.

2. Select the display colors you want to use for normal, warning and 
critical levels. By default, green represents normal level, yellow 
represents warning level, and red represents critical level.

3. Select a workgroup in the Workgroup List, and then select a field on 
which you want to set the threshold for the three levels. 

Note: To arrange the Workgroup Number, Workgroup Name, 
Field Name, or the Type columns in ascending or descending 
order, click the column heading. Click again to reverse order.

4. Click the Configure button or double-click the field. The Alerting 
Configuration dialog box for the selected workgroup opens:

The field you selected is 
described here

The dialog box varies, 
depending on the field 
you selected

The workgroup number
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5. Select Upward or Downward, as appropriate, configure the field’s 
threshold(s), and click OK. Your configuration is displayed in the 
Alerting Configuration dialog box.

Note: If you select Downward, the Normal above field is filled in 
automatically when you specify the warning level. For 
example:

6. If you want, configure an alerting sound to be played when the field 
value falls into the warning or critical level. To do so, select a file from 
the Sound File drop-down list. You can click the Play button to 
preview the sound. 

Note: Wave files are stored in the WAV folder under the MaxInSight 
folder. You can add your own sound file to this folder, and it 
will appear in the selection list. The duration of your sound file 
should be less than 5 seconds.

Note: Only one sound file can be used per workgroup.

7. When you are finished configuring, click OK.

When 8 was entered in 
the Warning field, 8 
appeared automatically 
in the Normal above 
field
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Figure 8. Example of a gauge view with alerting parameters set

Clearing an Alert Threshold Configuration
To quickly clear an alert threshold configuration on a field, open the Alert 
Configuration dialog box (Configure > Configure Alerting), select the 
workgroup and then the field whose configuration you want to clear, and 
click the Reset button. 

List of Fields
The following tables show all the fields supported in MaxInSight. They 
also show what fields are available to what kinds of views. (In the tables, 
Numeric means single workgroup view and multiple workgroup view.)

Table 1: Workgroup queue real time status fields 

In this view, alerting 
parameters are set 
to: 10 calls in queue 
is normal, 11-13 CIQ 
is at the warning 
level, more than 13 
CIQ is at the critical 
level
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Table 2: Agent availability status fields

Table 3: Daily performance statistics fields
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Index

Symbols
? in display data 15

A
alerts, configuring 24
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arranging views 8

B
background image, changing 9
bar view, configuring 20
broken connection 6

C
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background image 9
look of MaxInSight 9
number of digits displayed 15
view parameters 24

configuration, remembered 7
configuring

alerts 24
data displays 13
skin 9

connection with server broken 6

D
data displays

configuring 13
data source, choosing 6
data, displaying 13
digits displayed, changing number 

of 15
disabling workgroups 8
display

changing parameters 24
display mode 20
displaying data 13

F
fields

definitions 13, 27
descriptions 25
list 27

font color, changing 9
font, changing 9

G
gauge view

configuring 17
definition 17

H
history display mode 20
horizontal bar view, configuring 20

I
image, background, changing 9
installation 2
installation requirements 1

L
license required 1
logger servers 6
logging in 5

M
main window 6
menus, restore 8
monitoring workgroups 7
multiple rows, configuring 15
multiple workgroup views 15

O
overview of MaxInSight 1
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P
password, always save 6

R
real time display mode 20
reconnecting 6
required license 1
requirements, system 1
restore MaxInSight menus 8
rotate interval 15
rotating display 13
row count 15
rows, displaying multiple 15
row-type display 13
row-type views

multiple workgroups, displaying 
simultaneously 15

S
server IP address 5
single workgroup view 13
skin, changing 9
sound file

adding 26
configuring 26

starting MaxInSight 5
statistics period 19, 22
system requirements 1

T
threshold

clearing configuration 27
for alerts 24

thresholds, setting 25
time line view

configuring 18
definition 18

U
uninstalling 3

V
vertical bar view, configuring 20
View menu 8
view, changing parameters 24
views

arranging 8
moving 8

W
wav files 26
windows, moving 8
workgroup displays

configuring 13
workgroups

disabling 8
making available to monitor 7
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